Linuxathome.net
http://www.linuxathome.net/forum/

Getting Smoothwall to work with Optusnet Cable
http://www.linuxathome.net/forum/viewtopic.php?f=7&t=194
Page 1 of 1

Author:  meeshka [ Sun Oct 05, 2003 12:57 pm ]
Post subject:  Getting Smoothwall to work with Optusnet Cable

Hi All,

I've been trying to get Smoothwall (both v1 and v2) to work with my Optusnet Cable connection but am having no luck. I have two PCs (Redhat 8, Win98) attached to an 8 port switch. I've setup a spare PC to act as the firewall/router. It has two NICs in it, one attached via a cat-5 cable to the Motorola Surfboard modem, the other attached to the switch and being used as the DHCP interface.

The two PC's can get their addresses from the Smoothwall DHCP, but the smoothwall box cannot get an IP address from Optusnet. The Redhat box can get an IP address when attached to the modem directly, but the smoothwall box cannot.

I've read through the smoothwall guides and tried a number of things, but still cannot get it to work. I was wondering if anyone has had experience with Smoothwall and Optusnet, or knows if their are any issues with it?

Cheers.

Author:  meeshka [ Tue Oct 07, 2003 9:46 am ]
Post subject: 

Never mind, I have it working now. Problem was I didn't power off the modem (and wait > 30sec) for it to re-assign an IP address.

Author:  Oracle [ Mon Nov 17, 2003 11:16 am ]
Post subject: 

Hi,
Has anyone tried to get this working with Smoothwall Expres 2.0 beta 7:

I spent the weekend (about 20 hours) trying to get this linux firewall/gateway/router working. The marketing jargon says that Smoothwall is a best-of-breed Internet firewall/router, designed to run on commodity Intel (or compatible) PCs, and to give an easy-to-use administration interface to those using it.

My setup is:

PC 1: Smoothwall PC: A P3 866Mhz, 512Mb RAM, 10 Gb HD, 2 NIC (One Intel Ethernet Pro 10/100bps and Realtek 8139 10/100bps), 32 mb TNT video card.
The C drive on this PC is a removable cradle and hence I can run multiple OS thru changing the caddy. One caddy has WinXP, another caddy has Smoothwall and a third caddy has Mandrake Linux 9.1.
PC 2: WinXP P4 2.6.mhz, 512 Mb RAM, 160Bg HD and One Realtek 8139 NIC 10/100bps.
PC 3: WinXP P3 866 Mhz, 512Mb RAM, 160 Gb HD, One Realtek 8139 NIC 10/100bps, etc.
Network: Surecom EP-808SX 8-Port Mini 10/100 Switch. All PCs are networked and all worked when before the Smoothwall install.
Web: Optus Cable

The problem is:
I can connect from the Windows XP box (P4) to the smoothwall box both using http on port 81 and https using port 441 and get the admin web pages up.
However, I cannot get the internet up. I have followed the install/setup guide and the post install guide as well. Also, I read the SmoothWall FAQ and Troubleshooting guide where it states on page 15:
==============================================­
Q. I subscribe to @Home and I cannot get my Smoothie to get a DHCP lease from the @Home servers, why is this?
A. The @Home DHCP servers require that a client machine passes a specific hostname, before they issue a lease. To overcome this problem you should enter the hostname supplied by @Home in the DHCP hostname box on the Red NIC set-up page.
==============================================­

I did this change and yet still no web on the Windows XP P4 or windows XP P3. Any suggestions/help.

Page 1 of 1 All times are UTC + 10 hours [ DST ]
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/