Linuxathome.net

Linux news and help for home broadband internet users
It is currently Tue Oct 24, 2017 2:22 am

All times are UTC + 10 hours [ DST ]




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: SSL
PostPosted: Thu Sep 05, 2002 11:55 pm 
Offline
Newbie

Joined: Sat Jul 27, 2002 6:29 pm
Posts: 7
Hi guys, I want to run apache with name based hosting containing 2
normal(port 80) domains and 1 SSL domain. I set up the 2 domains on port 80
and one SSL domain. It all worked fine and I was cheery but I then
discovered that ALL of the domains include the ones on port 80 were secured
as well. I only want the SSL site to be secured. Reading around, I figured
it may have something to do with SSLDisable/Engine but am stuck. Any help would be
appreciated. Config is below:

NameVirtualHost 192.168.0.3:80
NameVirtualHost 192.168.0.3:443

<VirtualHost 192.168.0.3:80>
ServerName host1
DocumentRoot /path1
ServerAdmin root@localhost
ServerSignature email
</VirtualHost>

<VirtualHost 192.168.0.3:80>
ServerName host2
DocumentRoot /path2
ServerAdmin root@localhost
ServerSignature email
</VirtualHost>

<VirtualHost 192.168.0.3:443>
ServerName secure
DocumentRoot /secure
ServerAdmin root@localhost
ServerSignature email
SSLEngine on
SSLCertificateFile /etc/httpd/conf/ssl.crt/server.crt
SSLCertificateKeyFile /etc/httpd/conf/ssl.key/server.key
</VirtualHost>


I am using Apache and Mod_ssl


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC + 10 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group